Data recovery is complete. Most areas of the platform are now operational, and data accuracy has been fully restored.
There may be some latency in seeing values populate per instance, and we will monitor progress overnight.
Our engineering team will conduct a postmortem to identify and implement improvements that prevent a recurrence.
We apologize for the disruption and thank you for your patience today.
Posted Jul 09, 2026 - 13:15 PDT
Monitoring
Our team has made significant progress, and we are seeing improvements across the affected areas.
Activity participant data and API functionality have been restored, and the remaining metrics are actively recovering.
We are continuing to monitor closely and will share a final update once full recovery is confirmed. Thank you for your patience.
Posted Jul 09, 2026 - 10:07 PDT
Identified
At 8:00 AM UTC, we were alerted to an issue impacting Activity and Metrics Data on the Backstory platform.
Activity participant information may appear incomplete in the Backstory Web Application. In addition, metrics based on people or activity participant data may not display the most recent figures.
Our team has identified the root cause and is actively working on a resolution.
We expect a full data recovery and will post updates as we make progress.
We apologize for the inconvenience and appreciate your patience.
Posted Jul 09, 2026 - 06:15 PDT
This incident affected: Backstory Web-Application, Data Warehouse, Activity Intake APIs and Services, and Backstory Metrics Services.